Case 2. Point-to-point network type ↔ Point-to-multipoint network type

Device Configuration
R1
interface lo0
  ip address 1.1.1.1 255.255.255.255
interface fa0/0
  ip address 10.10.10.1 255.255.255.0
  ip ospf network point-to-point
  no shutdown

router ospf 1
  network 0.0.0.0 255.255.255.255 area 0
R2
interface lo0
  ip address 2.2.2.2 255.255.255.255
interface fa0/0
  ip address 10.10.10.2 255.255.255.0
  ip ospf network point-to-multipoint
  no shutdown

router ospf 1
  network 0.0.0.0 255.255.255.255 area 0
R3
interface lo0
  ip address 3.3.3.3 255.255.255.255
interface fa0/0
  ip address 10.10.10.3 255.255.255.0
  ip ospf network point-to-multipoint
  no shutdown

router ospf 1
  network 0.0.0.0 255.255.255.255 area 0

  각 장비에서 OSPF Neighbor 상태를 확인해 보면 다음과 같다.

R1# show ip ospf neighbor 

R2# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:01:58    10.10.10.3      FastEthernet0/0
R3# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:01:53    10.10.10.2      FastEthernet0/0

 R2와 R3는 Hello interval과 Dead interval이 동일하기 때문에 Neighbor 관계가 수립되지만, R1은 Hello interval, Dead interval이 다르기 때문에 Neighbor 관계가 수립되지 않는 것을 확인할 수 있다. 그럼 R1에서 R2, R3와 동일한 interval로 설정해 보자.

R1(config)# interface fa0/0
R1(config-if)# ip ospf hello-interval 30

  Hello interval을 변경하면 Dead interval은 자동으로 변경되니 별도로 Dead interval을 변경할 필요는 없다. 그럼 다시 OSPF Neighbor 상태를 확인해 보기로 하자.

R1# show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:01:59    10.10.10.2      FastEthernet0/0
R1#
Process 1, Nbr 2.2.2.2 on FastEthernet0/0 from FULL to DOWN
Process 1, Nbr 3.3.3.3 on FastEthernet0/0 from LOADING to FULL, Loading Done
R1#
R1# show ip ospf neighbor  
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:01:59    10.10.10.3      FastEthernet0/0
R1#
Process 1, Nbr 3.3.3.3 on FastEthernet0/0 from FULL to DOWN, Neighbor Down
Process 1, Nbr 2.2.2.2 on FastEthernet0/0 from LOADING to FULL, Loading Done
R1#
R1# show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:01:59    10.10.10.2      FastEthernet0/0
R2# 
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
R3# 
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
Process 1, Nbr 1.1.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done

  R1은 Point-to-point network type 이기 때문에 단 하나의 Neighbor 관계만 수립할 수 있다. 그런데, Hello Packet 정보를 확인해 보니 Neighbor로 인정할 수 있는 장비가 두대인 것이다. 실제로 R1에서는 장비 두대와 연결되어 있다고 판단하지 않는다.

  R1은 Router-id ‘2.2.2.2’를 가진 장비와 Neighbor 관계를 수립한 상태에서 Router-id ‘3.3.3.3’의 Hello Packet을 받게 되면 ‘2.2.2.2’가 ‘3.3.3.3’으로 변경되었다고 판단하고 Neighbor 관계를 새롭게 수립하는 것이다. Point-to-point network type으로 구성된 interface에 장비 2대와 연결되어 있을 것이라는 것은 상상조차 하지 못하기 때문이다.

 그래서, Point-to-point network type은 두 대 이상의 장비와 연결된 망에서는 절대로 설정하면 안되는 Network type이다. 만일 두 대 이상의 장비와 연결되어 있는 상테에서 특정 장비하고만 Neighbor 관계를 수립하고 싶다면 Point-to-multipoint non-broadcast network type으로 만들어서 Neighbor 명령어를 사용하는 방법을 사용하여야 한다.